Issues with version 1.4 beta

Jan 10, 2014 at 5:04 PM
Hi,

first of all thanks for updating this sofware and implementing the requested features.

I do have some issues with version 1.4 though:
When I start the program it complains about "Could not find drive l:" - when I click OK here it comes up with a totally empty configuration, not showing the drives I had configures in 1.3 anymore.
At first I thought that was because internal DB changes - so I tried reconfiguring ...
When I try to add drive H: from the "all drives" tab, I do get the same error message as during startup, complaining about missing drive I: .
When I try to add drive H: manually, I get an error message saying "You already have specified that drive".
I did a full un-install and re-install, with no change.

I´m afraid something is broken in 1.4, hope you can fix it, as I really like the new features you implemented. If you think this is specific to my setup, let me know how to troubleshoot that ...

Thanks - HacMac
Coordinator
Jan 10, 2014 at 6:02 PM

I'm sorry to hear that, I will get at it as soon as possible.

Jan 10, 2014 at 6:14 PM
Great,

thanks. Just for your information: When I replace the .exe with the one from version 1.3 everything is back to normal - even my old configures drives show again.

Must be something with 1.4 ...

Good luck - HacMac
Coordinator
Jan 10, 2014 at 6:31 PM

Can you send me your drives.xml config file?

Coordinator
Jan 11, 2014 at 1:11 PM
Just uploaded the new 1.4.1 version so please download it and see if it's working for you.
Jan 11, 2014 at 5:06 PM
Hi,
just tried 1.4.1 - it is getting better, but still some issues ... thanks for your support though!

With 1.4.1 it shows the list of configured devices again and also lets me add a device correctly manually.

Still there is an issue with the device list: When I click on this tab or on the button "refresh" I do get a "device not ready" error and the list stays empty. I enabled logging and looked at the log, it looks like it has issues with on of the drives I had configured before, but is not connected. While for two not connected drives it corretly states "device not connected ...." in the log, there is one entry with no drive letter where the log says "device not ready":

I tried to remove all drives and only configures 1 connected drive (H:) but after a restart it still complains about a "device not ready" and empty device list - not sure what it is looking for.

Here is my drives.xml:

<?xml version="1.0" encoding="utf-8"?>
<Root>
<DriveInfo>
<ID>5</ID>
<Drive>H:\</Drive>
<VolumeName></VolumeName>
<TimeInterval>3</TimeInterval>
<TimeUnit>m</TimeUnit>
<Status>1</Status>
<Connected>true</Connected>
</DriveInfo>
</Root>

Thanks for your support - HacMac